Wrong_browser_warningYou need Firefox, Internet Explorer, Chromium, or iOS to use Cocoon
Art_add_to_firefox
Download_firefox

Firefox

To install Cocoon for Firefox, open or download the latest version of Firefox. Then revisit this page using the Firefox browser to download the Cocoon add-on.

Supported Versions:
Firefox 4.0+

System Requirements:
Windows 7, XP and Vista, Mac OS X.4 or newer, and most modern Linux systems

Art_goto_ios_lrg

Art_goto_chrome

Art_goto_explorer