Wrong_browser_warningYou need Firefox, Internet Explorer, Chromium, or iOS to use Cocoon
Art_add_to_chrome
Btn_download_cocoon_for_chrome_mac

Chrome  Ie_beta

There is a customized version of Chromium made especially for Cocoon. Download it using the "Cocoon Chrome (Mac)" button.

Supported Versions:
Cocoon Customized Chromium

System Requirements:
Mac OS 10.4+ (Intel Only)
Wrong_browser_warning Windows - coming soon!

Art_goto_ios_lrg

Art_goto_firefox

Art_goto_explorer